f

2014-12-23

Solution of grep: warning: GREP_OPTIONS is deprecated; please use an alias or script

MSYS2のbashを起動すると以下の警告が表示されるようになった。

grep: warning: GREP_OPTIONS is deprecated; please use an alias or script

.bashrcで指定しているGREP_OPTIONが原因のようだ。

GREP_OPTIONS="--color=auto --binary-files=without-match"

この問題については以下での議論が参考になった。

Change to alias and rmove decaprated GREP_COLOR by mimi1vx · Pull Request #3341 · robbyrussell/oh-my-zsh https://github.com/robbyrussell/oh-my-zsh/pull/3341

この警告はgrep version 2.21から出るようになったようだ。grep 2.21のマニュアルのGREP_OPTIONSに以下の記載がある。

This variable specifies default options to be placed in front of any explicit options. As this causes problems when writing portable scripts, this feature will be removed in a future release of grep, and grep warns if it is used. Please use an alias or script instead.

スクリプトでこの変数が問題を起こすので、今後のリリースではこの変数をサポートしないらしい。引き続き設定を使うなら,警告にあるようにaliasにしたらいい。aliasはシェルスクリプトでは無視されるので安心だ。たとえば以下のように設定すれば問題ないだろう。

GREP_OPTIONS="--color=auto --binary-files=without-match" ## grep 2.21
alias grep="grep $GREP_OPTIONS"

これでターミナルの起動時に警告が表示されなくなり安心した。

0 件のコメント:

コメントを投稿